guzziriders.org - moto guzzi forum Homepage
Forum Home Forum Home > Technical > Small Blocks
  New Posts New Posts RSS Feed - V7 I 2011 engine cuts off
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

V7 I 2011 engine cuts off

 Post Reply Post Reply
Author
Message
pedropina View Drop Down
Guzzino
Guzzino


Joined: 23 Dec 2017
Location: Portugal
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote pedropina Quote  Post ReplyReply Direct Link To This Post Topic: V7 I 2011 engine cuts off
    Posted: 23 Dec 2017 at 14:07
Hello!

First of all, allow me to introduce myself, since this is my first post in this forum. I'm Pedro, from Portugal, and I recently (2 months ago) acquired a used Moto Guzzi V7 I Cafe Classic from 2011 (a little bit customized, not by me). 

After a few rides it started to behave strangely (the previous owner assured me it never did that with him). By "that", I mean the engine just cuts off, randomly, either in idle or in motion, not in neutral. 

I've taken it to the Guzzi dealer in Lisbon twice and they can't figure out what it is, mainly because she behaves well in there. 

Some of the symptoms include: hiccups when accelerating, without the engine cuting off, or lose of power, feeling the engine "sluggish", like there's only one cylinder working, and cuting off as soon as i stop with the hand in the clutch. 

Have any idea what it might be?

Thank you very much
Back to Top
Cylvabirch View Drop Down
Senior Member
Senior Member
Avatar

Joined: 02 Jun 2014
Location: Whitehill
Status: Offline
Points: 241
Post Options Post Options   Thanks (0) Thanks(0)   Quote Cylvabirch Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jan 2018 at 16:35
Hi Pedro, welcome.
It would be worthwhile going through the basics first, change the spark plugs making sure the gap is correct 0.45 mm, change the original Moto Guzzi plug caps to new NGK ones. Using the service guide, which can be downloaded, check and adjust the inlet and exhaust valve clearances, I suggest 0.2mm for both, with the engine cold after an overnight pause.
Put a strong dose of injector cleaner in the petrol tank and run the engine really hard for a week or so.
Try that first before going further.
David.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.00
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.