guzziriders.org - moto guzzi forum Homepage
Forum Home Forum Home > Technical > Singles
  New Posts New Posts RSS Feed - Cali 3 fuel pump issue
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Cali 3 fuel pump issue

 Post Reply Post Reply
Author
Message
Dallies101 View Drop Down
Guzzino
Guzzino
Avatar

Joined: 23 Apr 2019
Location: Kent
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dallies101 Quote  Post ReplyReply Direct Link To This Post Topic: Cali 3 fuel pump issue
    Posted: 07 Jul 2019 at 16:01
hey guys, my Cali 3 fuel pump won't prime. All other electrics work and the bike will turn over. I've got a new relay but no difference....... Until I changed it with one on the other side of the bike and then the pump wined. No tank on so no fuel. I swopped them back and then nothing again. Swopped them over and got the wine. I'm not sure which location is the fuel pump relay and also, I can't remember which is which now as the pump has now stopped wining!!! Does it matter which relay goes in which slot??? 🤔 Could I of blown a fuse by swopping them maybe? Does the wine on the fuel pump mean its OK or was it just coincidence? I'm at a loss at the moment and just want my bike back on the road!!!! 😔 TIA to anyone who can help me!!! 
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3931
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jul 2019 at 17:00
First thing I would do is put tank on with fuel in . Put all your relays in I believe they are all the same . If no start then check all connections and hope it's not the ECU 
1100 sport corsa , Yam R1, guzzi 650tt rider
Back to Top
Dallies101 View Drop Down
Guzzino
Guzzino
Avatar

Joined: 23 Apr 2019
Location: Kent
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dallies101 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jul 2019 at 18:07
I'll give it a go!!! Thanks for the reply and I'll report back 
Back to Top
bexupnorth View Drop Down
Falcone
Falcone
Avatar

Joined: 18 Jan 2016
Location: North Yorkshire
Status: Offline
Points: 90
Post Options Post Options   Thanks (0) Thanks(0)   Quote bexupnorth Quote  Post ReplyReply Direct Link To This Post Posted: 09 Jul 2019 at 11:48
http://www.guzziriders.org/cali-ev-wont-start-any-ideas_topic7060.html

Have a look amongst this little lot. I had something very similar which eventually turned out to be the connector from the fuel pump underneath the tank. Loads of really good advice on how to test almost everything in the circuit.

Hope you get sorted.

Ade
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.02
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.078 seconds.