guzziriders.org - moto guzzi forum Homepage
Forum Home Forum Home > Technical > Spine Frame
  New Posts New Posts RSS Feed - 1100 F.I. Sport 'issues'
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

1100 F.I. Sport 'issues'

 Post Reply Post Reply
Author
Message
simonnorthroad View Drop Down
Senior Member
Senior Member


Joined: 16 May 2017
Location: Bath, UK
Status: Offline
Points: 141
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonnorthroad Quote  Post ReplyReply Direct Link To This Post Topic: 1100 F.I. Sport 'issues'
    Posted: 03 Apr 2021 at 10:05
Struggling with my first fuel-injected Guzzi, an import.
First outing was a 30 mile round trip for a pre-registration MOT without problems, then it was laid up for almost a year, partly due to the Pandemic and partly due to waiting for DVLA to issue me with the V5c.
Now, road-legal, with plenty of fresh Super Unleaded and also a fully charged battery, it starts, runs, and will travel 50 yards before spluttering to a halt, each time.
One side of the tank has a weird vacuum tap arrangement, the other a manual tap.
Im much more familiar with carburettored bikes so Im on a steep learning curve here. Ive got the chance to borrow a mate's F.I. Cali  fuel-pump to try. Anything else logical to look for? I know 'most fuel problems are electrical and vice versa' but it does seem like fuel's not getting through.
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 4711
Post Options Post Options   Thanks (1) Thanks(1)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2021 at 10:13
Can you hear fuel pump prime 
1100 sport corsa , Yam R1, guzzi 650tt rider
Back to Top
simonnorthroad View Drop Down
Senior Member
Senior Member


Joined: 16 May 2017
Location: Bath, UK
Status: Offline
Points: 141
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonnorthroad Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2021 at 10:15
Sorry,yes I should have said. Yes it does appear to make the right noises, at least, on switching ignition on
Back to Top
Brian UK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 13 May 2014
Location: Surrey
Status: Offline
Points: 15612
Post Options Post Options   Thanks (1) Thanks(1)   Quote Brian UK Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2021 at 10:28
Is the fuel filter clean? One gummed up would do exactly what you are witnessing.
Brian.

Better 5 minutes late in this world than years early in the next.
Back to Top
BondEquipe View Drop Down
Senior Member
Senior Member
Avatar

Joined: 10 Dec 2014
Location: Barnacle
Status: Offline
Points: 1688
Post Options Post Options   Thanks (1) Thanks(1)   Quote BondEquipe Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2021 at 12:17
Have you tried with the fuel tank open?  I don't know what the venting arrangement is on thee but it does sound like a fuel starvation issue one way or another so start with the simple things!
Stephen
Black & Gold LM2
+ Other Bikes & Projects!
Back to Top
Guzzi G View Drop Down
Falcone
Falcone


Joined: 03 May 2020
Location: Durham
Status: Offline
Points: 46
Post Options Post Options   Thanks (1) Thanks(1)   Quote Guzzi G Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2021 at 16:34
The " weird vacuum thing" is the pressure regulator,  the other thing is the petrol tap, is it electronic? (Wires going to it) or manual? (It should be left in the open position) there is a filter on the tap, (inside the tank like the old taps) and the big filter under the tank,
I would check the flow first๐Ÿ‘

Back to Top
simonnorthroad View Drop Down
Senior Member
Senior Member


Joined: 16 May 2017
Location: Bath, UK
Status: Offline
Points: 141
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonnorthroad Quote  Post ReplyReply Direct Link To This Post Posted: 04 Apr 2021 at 09:56
Hi,
Thanks for all your feedback. Plenty of food for thought.
The Pressure regulator is manual, no wires going to it.
The tank has a breather, and isnt full to the brim, plenty of air sloshing about in there with the fuel, in terms of hydraulic lock.
Ive not had a look for the fuel filter. My mate who has a spare fuel pump, apparently has a spare fuel filter too. Ill investigate both.
Certainly last time I had the tank off to tidy up the wiring, before this problem arose,  and made the mistake of switch the petrol on, it sprayed fuel everywhere!
Back to Top
Guzzi G View Drop Down
Falcone
Falcone


Joined: 03 May 2020
Location: Durham
Status: Offline
Points: 46
Post Options Post Options   Thanks (1) Thanks(1)   Quote Guzzi G Quote  Post ReplyReply Direct Link To This Post Posted: 04 Apr 2021 at 10:40
Pressure sensor has no wires, there are 2 types of tap,(other side of the tank) one is electric, (might have a bad connection), other type is manual, (you can turn it off for maintenance by turning the bottom of it) is it fully on? Is the filter in the tank blocked? 
Hope this helps ๐Ÿ‘
Back to Top
Wits View Drop Down
Admin Group
Admin Group
Avatar

Joined: 13 May 2014
Location: Shropshire UK
Status: Offline
Points: 677
Post Options Post Options   Thanks (1) Thanks(1)   Quote Wits Quote  Post ReplyReply Direct Link To This Post Posted: 04 Apr 2021 at 23:18
You should should hear fuel pump run when you turn ignition key, can't remember if its timed or just pressurises the system.....Before you press start  button.
Fuel filter is outside ( Under )the tank..... could be blocked or restricting flow old fuel.

Hope you have success with the fault.... 
BMW 1200RTLC carbon BLack
Breva 1100 2005 in Black SOLD.....
St George's Telford Shropshire.
Back to Top
simonnorthroad View Drop Down
Senior Member
Senior Member


Joined: 16 May 2017
Location: Bath, UK
Status: Offline
Points: 141
Post Options Post Options   Thanks (0) Thanks(0)   Quote simonnorthroad Quote  Post ReplyReply Direct Link To This Post Posted: 05 Apr 2021 at 12:39
Yes I can hear the fuel pump priming/turning on, with the igntion key, and yes the fuel tap screws/unscrew, plus I have another in-line red tap about 1cm down the fuel-hose, probably unnecessarily!
Ill be delving into these, checking fuel flow, looking for the fuel filter after Easter. Thanks all.Will let you know how I get on,
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.078 seconds.